Building Java Applets with Visual Café 

CS 102-02 (Spring 1998)

Under the Hood

In the Introduction to Java lecture, I mentioned that Java isn’t the native language of most computers: Java has to be translated into a form that the computer can understand. One of the things that make Java run anywhere (or almost anywhere) is that Java source code (what you write) is translated into Java bytecode. The bytecodes are stored in a special binary file format, called a class file. When you run a Java program, the program is loaded into a Java virtual machine (a.k.a. a “Java VM”), and the bytecodes are translated in to machine language. (Many other languages, such as C++ or C, but not Perl, go from source code straight to machine language.) The figure below summarizes the process:
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Giving Applets a Helping Hand

For Java applications that would be the whole story, but since applets aren’t full-blown applications themselves, they need a little help to get up and running. Usually this “help” will come from one of two places: a browser (Netscape Navigator or Internet Explorer) or an applet viewer (a stripped-down browser which doesn’t do anything except run applets). The browser doesn’t want to see a Java applet though — it wants to see HTML. To include an applet in an HTML page, use the HTML <APPLET> tag. For example to include Sun’s Tic-Tac-Toe applet, you would write:

<APPLET CODE=”TicTacToe.class” WIDTH=”120” HEIGHT=”120”>

</applet>

Visual Café Does the Dirty Work

With Visual Café, we don’t need to worry about the details of how the Java code is compiled, or what the applet tag looks like. Instead we just Visual Café to build our applet for us. In the next two sections, we’ll look at two different ways to build applets: starting from scratch and using the Java HTP example code.

1. Starting from Scratch

2. Start the Visual Café application by double-clicking the Visual Café icon in the folder Maclab Resources:Applications:Programming:Visual Café.

3. You’ll see the Visual Café integrated development environment (IDE) pop up with two windows open in the lower left corner:
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5. You can close the two windows (dbNAVIGATOR and Component Library) in the corner, because we won’t be using them.

6. With Visual Café (and most other IDEs), you need to create a project file, which tracks all the files related to an applet (or application). To create a new project, choose New Project… from the File menu.

7. Visual Café will ask what kind of project you want:
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9. Click on Basic Applet, then choose ‘Create’.  You’ll see two windows appear: an untitled Visual Café project window and an applet window:
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11. We’re going to build our own applet, so we need to do two things: close the Applet1 window, and remove the Applet1 file from the project.

12. After closing the Applet1 window (not the untitled project window), click the Files tab of the project window. And then click the file icon next to “Applet1.java”:
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14. From the Project menu, choose Remove “Applet1.java”:
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16. Now you’ve got an Applet project, but it doesn’t have any files in it. That’s okay, because we’ll add one shortly.

17. After you’ve created a new project, you should save it immediately. You should create a new folder for the project and save the project file itself and all related files in that folder. For right now, we’ve only got the project file to worry about, so choose Save from the File menu, and then use the Save dialog to create a new folder and save the project file. For this tutorial save the project as Sample in a folder called Sample.

18. Now you’ve got a project file and a project folder, but no Java code written yet. Visual Café includes an editor to make it easy for you to write and edit programs. To create a Java source file, choose New from the File menu and you’ll get an untitled text editing window.

· Type in the text of the Welcome applet from Figure 1.2 in the Java: How to Program book. (Later we’ll start with an already-created Java file, but for right now, be sure to type in the code exactly as you see it in the figure.) As you type, Visual Café helps you with a couple different features:

· Syntax highlighting — Java keywords are highlighted in bold, and strings in red. After you typed “import” and hit the space bar, Visual Café bolded the word import. When you typed the quote mark in the call to drawString(), the text appeared in red.

19. Matching braces — When you typed the closing parenthesis in paint (Graphics g), Visual Café flashed the matching parenthesis so you’ll know which ones match. This works for the curly braces as well.

20. Once you finished typing, you should save your program. Save it in the same folder where you saved your project file earlier (Sample, if you’ve been following along). One of the rules of Java is that the file MUST have the same name as the class defined in it, with a ".java" tacked on to the end. Since our file defines the class Welcome, it has to be called "Welcome.java".

21. If you’ve made it this far, you should now have a text window labeled Welcome.java, like the one below:
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23. Now we’ve got a project file and a Java source file, but the Java source isn’t included in the project yet. To add files to the project, choose Files… from the Insert menu:
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25. You’ll see the Insert Files dialog box, which you’ll use to add files to the project:
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27. Click the Welcome.java file from your Sample folder, and then click Add. Next, click Done and you’ve added the file to the project. Your project window should now look like:
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29. Save the project, and then run your applet by choosing Run form the Project menu:
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31. Notice that we’re running an applet (rather than an application), but we haven’t created an HTML file with an applet tag. No problem, Visual Café took care of that and created an HTML file automatically for us. We never compiled the Java source code, but Visual Café took care of that too. The HTML file is loaded into the Applet Viewer, and the code executes. Once it’s all done, you should see:
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33.  That’s it: You’ve created a new Visual Café project from scratch and run it.

Building Projects with the Example Code from Java: How to Program

Although you’ll sometimes start from scratch, you might also want to run the example code which is included in the book. All of the example code is stored on the Maclab server (Maclab Resources) in the folder Courses:Spring 1998:CS102-02:examples. (By the way, you can start Visual Café by double-clicking any of the files in the examples folder.) With the examples, the code is already written, but you still need to build a project. The steps are similar, but there are a few differences.

1. You should still start with a Basic Applet project (assuming the example code is for an Applet — some example code is for applications).

2. Dump the automatically-created applet file by closing the window and removing the Applet1 file from the project.

3. Use Open from the File menu to open the example code (the .java file) from the examples folder .

4. Save the example file (using the same name) into the project folder you’ve created.

5. While the example source file window is active, choose Add "filename" from the Project menu, and the file will be added to the project. (This has the same effect as using Files… from the Insert menu as we did before, but it only works for the active file.)

Visual Café Tips and Tricks

· Visual Café includes many powerful features for working with Java, and the two most important are:

· Debugging — You can pause running Java programs, check out a variable’s value and step through your program one line at a time.

· Visual design — More advanced graphics features make it easy to use Visual Café as a drawing program, and then have Visual Café generate the Java code automatically.

If there’s time, we’ll look at the visual design later in the quarter, but the debugging features can be helpful right away.

If you want to debug a Visual Café program, just choose Debug (instead of Run) from the Project menu. Your program will start to run, you’ll see the Applet Runner start up, and then your program will pause on the first line, and the Project menu will change to a Debug menu:
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The Debug menu choices control when your program starts and stops, and are summarized in the table below.

Menu item
Meaning

Continue
Keep going until something else stops the program (for example, an error or breakpoint), or it finishes executing.

Pause
Stop whatever the program’s doing, and wait until I choose Continue.

Stop Debugging
Quit debugging which also stops the running of the program.

Restart
Start over again.

Step Into
If the line about to be executed has a procedure call, then step through each line of the called procedure.

Step Over
If the next line is a procedure call, execute as a single statement, and move on.

Step Out
Whatever procedure you’re in right now, continue all the way to the end of the procedure, and then stop at the line immediately following the original procedure call.

Continue to Here
Keep going until something else stops the program (for example, an error or breakpoint), or execution reaches the line the cursor is on.

Break on Exceptions
If an exception (like an error) is thrown, stop executing (but not debugging) just as if a breakpoint were hit.

With your program paused on the first line, you should see something like the image below:
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The highlighted line is the Java line about to be executed. If you look on the left-hand side of the image above, you’ll see a gray strip with dots at each line and a big red dot on one line. The red dot represents a breakpoint, which means that once program execution reaches that point, it will stop and return to the debugger (from the Applet Runner). If you click on a gray dot, it will change to a breakpoint, and if you click on a breakpoint, it will revert to a red dot.

Breakpoints are handy if your program works fine up to a point, and then goes haywire. You can stick in a breakpoint at the last line you’re sure works correctly, and then begin debugging. Once you get to the breakpoint, you can step through one line at a time to better understand what’s going on in the program.

You’ll usually want to use breakpoints together with Watch variables. The Watch window, shown in the image below, displays a list of variables and their current values. (You can display the Watch window by choosing Watch from the Windows menu, or with Shift-Command-W.)
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1. The Watch window starts empty, but you can variables to watch in two ways:

2. Click on the left side of the Watch window and type in an expression.

3. Select the text of the variable’s name in the source file, and then chose Watch Variable from the Source menu.

A Little Debugging Strategy

1. If you’re program isn’t working the way you expect, you can try the following steps:

2. If it works up to a point, put in a breakpoint at the last good line of code.

3. When the code stops at the breakpoint, add Watch Variables for any relevant variables, (For example, the loop counter in a loop and perhaps the variable being modified in the loop.)

4. Step through your code one line at a time. If you know that all the called procedures work correctly (for example, if they’re part of the Java distribution), you can use Step Over. If you wrote the methods that are being called, and you’re not sure if they work, you can use Step Into to walk through each line of code in the called methods. (Once you’re satisfied that a method works alright, you can use Step Out to finish it without walking through every remaining line of code.)

5. Keep an eye on the Watch window, and be sure that each variable has the value expect.

Serving Up a Freshly Written Applet

Once you’ve ironed out all the bugs in your applet, you’ll want to test it out on the Web. To do that, you need to move all the needed files to a Web server. For this section, I’ll assume that you’re working in the MacLab and have an account on the classes server.

1. Using the Mac Chooser, click on AppleShare, choose the CS zone (not the CSMacLab zone) and then click CS Classes and press OK.

2. Choose your Home volume, which should then appear on your Mac’s desktop.

3. If you don’t have a folder called "html" in your Home volume, you should create one.

4. Create another folder inside the html folder, and name it something descriptive of the applet. (The project name would be fine.)

5. Switch to the folder in which you defined your project and related files (either on the Mac’s hard drive or a floppy/Zip). You need to copy over at least the HTML file (the one with the <APPLET> tag) and the class files. The easiest thing to do is to select the HTML file (called Automatic.html if you let Visual Café create it for you), and the classes folder and then drag them into your newly created project folder on the classes server.

6. Once you’ve done that, you’re ready to go. Fire up your trusty browser, and enter the URL, which should look like:

7. http://www.classes.cs.uchicago.edu/~loginname/project-name/some.html
8. Your applet should pop up and bring a smile to your face.







